Fundebug前端JavaScript插件更新至1.8.0,兼容低版本的Android浏览器

摘要: 兼容低版本 Android 浏览器,请大家及时更新。

Fundebug 前端 BUG 监控服务

Fundebug是专业的程序 BUG 监控平台,我们 JavaScript 插件可以提供全方位的 BUG 监控,可以帮助开发者第一时间定位 JavaScript 执行错误、HTTP 请求错误以及资源加载错误。并且,我们可以记录用户行为、“录制”用户操作视频,帮助开发者快速复现 BUG,提高 Debug 效率。

1.8.0 兼容低版本 Android 浏览器

用户和我们反馈,Fundebug 在 Android 4.4 与 5.1.1 浏览器上会报错,我们在 1.8.0 修复了这个问题,请大家及时更新插件。

通过优化 Babel 配置,我们兼容了一些低版本的浏览器:

{
"presets": [
[
"@babel/preset-env",
{
"targets": {
"ie": 6,
"android": 4,
"ios": 8
}
}
]
]
}

可知,Fundebug 插件最低兼容 IE 6,Android 4 以及 iOS 8。注意,我们保证 Fundebug 插件在这些浏览器下不会出错,但是并无意于为低版本浏览器提供全面的 BUG 监控服务。例如,我们的录屏功能仅支持一些高版本的浏览器,IE 6 ~ IE 10 均不支持。

最后,感谢 Fundebug 用户闁鑅疯狂紫萧的反馈。

参考

关于Fundebug

Fundebug专注于JavaScript、微信小程序、微信小游戏、支付宝小程序、React Native、Node.js和Java线上应用实时BUG监控。 自从2016年双十一正式上线,Fundebug累计处理了20亿+错误事件,付费客户有阳光保险、核桃编程、荔枝FM、掌门1对1、微脉、青团社等众多品牌企业。欢迎大家免费试用

版权声明

转载时请注明作者 Fundebug以及本文地址:
https://blog.fundebug.com/2019/06/03/fundebug-javascript-1-8-0/

您的用户遇到BUG了吗?

体验Demo 免费使用